1971 LT1 Owners - Corvette Forums - Corvette Enthusiast Site

Go Back   Corvette Forums - Corvette Enthusiast Site > Corvette Models > Corvette C3 Forum

LinkBack Thread Tools Search this Thread
Old 10-31-2006, 10:06 AM
Join Date: Oct 2006
Posts: 2
Default 1971 LT1 Owners

My 71 LT1, which is 100% original, runs poorly at speeds below 3500 RPM. Everyone I talk to say that it is normal for this car and that I should always try to keep the RPM's in the top 2/3 of the range. If anyone owns a 71 LT1 that doesn't run like stink below 3500 RPM, please respond. I actually hate driving mine due to this and am getting ready to give up if I can't correct the problem. It actually feels like it is missing. By the way, this car has been completely and professional restored from the ground up and is exactly as it was when original.

Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
1971 Chevelle LS1 H/C 20K grafking Corvettes for Sale 0 08-28-2007 09:33 AM
WTB 1971 Original C3 Radio Knobs AM/FM Yellow1971Roadster Parts/Other Sales 1 12-24-2006 07:40 PM
1971 LT1 Missing at low RPM etagretaw General Tech 0 10-30-2006 12:35 PM
1971 stingray for sale? CEPitbull1025 Corvette C3 Forum 4 09-24-2006 06:53 PM
how many lady Corvette owners, men corvette owners CORVETTE LADY Off Topic 8 09-06-2006 02:48 PM

1971, 1971lt1, corvette, forum

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 10:55 AM.