1987 VETTE shuts down after 15 min. - Corvette Forums - Corvette Enthusiast Site

Corvette C4 Forum 1984 through 1996

1987 VETTE shuts down after 15 min.

Reply

 
 
 
  #1  
Old 05-31-2018, 09:30 AM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 1
Default 1987 VETTE shuts down after 15 min.

1987 corvette replaced distributor/complete,fuel pump,all injectors,ECM/PROM.Car still shuts down after 15 min.Won't start until it cools down.
 
Reply With Quote
  #2  
Old 06-01-2018, 10:08 AM
73shark's Avatar
Super Moderator
Join Date: Apr 2006
Location: KC, MO area
Posts: 2,595
Default

Welcome to the forum.

Try putting a fuel pressure gauge on it and monitoring the fuel pressure right before shutdown. If the pressure goes to zero, check the fuel pump relay. If it is operating normally then I think it points to the fuel pump.
 
Reply With Quote
  #3  
Old 06-26-2018, 11:02 PM
Wes King's Avatar
Junior Member
Join Date: Jun 2018
Location: Forney, Texas
Posts: 4
Default

I have a beautiful white 1994 Corvette, with a repetitive problem of turning off, simply dies on hwy, back roads or anywhere. I’ve read most post of same caliper, and I have not read the remedy of my Vettes problem. Same symptoms will start back up after 10-15 min. Dash displays sys (3x) no codes. Service engine soon and batt alerts are displayed until it cools and restarts. No alerts . No stall, just dies.
where to begin my search for correct repair sequences..? I’ve only had this Jewel for 30 days, would like to fix prob and drive the living Heck out of er. I’m pretty good with suggestions , as well to be appreciated ..
wes.
 
Reply With Quote
  #4  
Old 06-27-2018, 01:41 PM
Ladybug's Avatar
Member
Join Date: May 2018
Location: Pensacola, FL
Posts: 56
Default

My husband asks if you have a standard coil. Says that could be the problem.
 
Reply With Quote
  #5  
Old 06-27-2018, 03:42 PM
73shark's Avatar
Super Moderator
Join Date: Apr 2006
Location: KC, MO area
Posts: 2,595
Default

Wes King: Welcome to the forum.
If you have a check engine light then you need to have it scan for codes. Most auto parts stores will do it for free.
 
Reply With Quote
  #6  
Old 06-28-2018, 12:13 AM
Wes King's Avatar
Junior Member
Join Date: Jun 2018
Location: Forney, Texas
Posts: 4
Default

Thanks shark,
i have readers and jumper wire. Service engine soon ONLY comes on with the Batt Alert on dash module.
when she starts up again?, no codes or cluster/ dash module alerts. I believe I can follow precise instructional suggestions. I’m wondering which possible repair would be best to start with .?
fuel pressure. Column/ ignition, distributor , coil, abs, tps, or any other possibility?
thanks for the info. Glad to be add...
 
Reply With Quote
  #7  
Old 06-28-2018, 12:15 AM
Wes King's Avatar
Junior Member
Join Date: Jun 2018
Location: Forney, Texas
Posts: 4
Default

I did do not have any History codes displayed
 
Reply With Quote
  #8  
Old 06-28-2018, 10:11 AM
Ladybug's Avatar
Member
Join Date: May 2018
Location: Pensacola, FL
Posts: 56
Default

Wes - my husband says, "I am thinking he has a HEI ignition, so most likely his problem may be a collapsed fuel sock in the fuel tank."
 
Reply With Quote
  #9  
Old 07-01-2018, 10:36 PM
Wes King's Avatar
Junior Member
Join Date: Jun 2018
Location: Forney, Texas
Posts: 4
Default

Thank you ,,
”my husband says”. I’ll give er a look see..
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.