CEL: EVAP leak & system lean? - Corvette Forums - Corvette Enthusiast Site

Go Back  Corvette Forums - Corvette Enthusiast Site > General > General Tech
Reload this Page >

CEL: EVAP leak & system lean?

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

CEL: EVAP leak & system lean?

Reply

 
 
 
  #1  
Old 03-28-2018, 01:45 AM
God's Avatar
God
God is offline
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 2
Default CEL: EVAP leak & system lean?

Hello everyone,

My 2009 Corvette is currently showing CEL codes P0171 and P0174 (Bank 1 and 2 too lean) and P0442 P0455 (Small leak).

I replaced the gas cap with a brand new OEM cap and the CEL is still showing.

Not sure what else could cause the problem, I have noticed the car seems to idle a little rough on start-up but smooths out when the car is warm, I'm guessing the throttle body needs to be cleaned? Could this possibly throw a code?

Any input would be appreciated.
 
Reply With Quote
  #2  
Old 04-12-2018, 11:31 PM
God's Avatar
God
God is offline
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 2
Default

Was just the gas cap. lol
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.