Notices
Corvette C4 Forum 1984 through 1996

car runs bad after 20 minutes

  #1  
Old 08-07-2014, 07:37 PM
Junior Member
Thread Starter
Join Date: Aug 2014
Location: minnesota
Posts: 1
Default car runs bad after 20 minutes

I own a 40th anniversery. auto, with 60 thousand miles. it has been a wonderful car. this year after i took it out of storage, it ran great for 125 miles and then,
when in drive at about 45 mph it starts to miss baldy. the more i run it the worse the condition gets. it almost feels like vapor lock on the old cars. i took it to a vet "expert-haha" mechanic. he changed plugs and wires. and it made almost no difference. he said might be torqe converter - i took it to transmission specialist and he says not any transmission problems. now i will run it for about 20 minutes and it starts the same thing over again and as I said i gradually gets worse. also when hot and sits a while and then I try to start it it hardly turns over. any Ideas will be greatlly appreciated. I might have to sell because I don't have thousands of dollars to throw at it to figure it out.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
munson1578
Corvette C3 Forum
3
05-19-2011 09:30 PM
white88
Corvette C4 Forum
8
08-31-2006 02:56 PM
Guy
Interior & Exterior
1
08-25-2006 03:35 AM
parkit
Corvette C4 Forum
6
07-25-2006 02:10 AM
bertsbassbox
Corvette C4 Forum
5
05-31-2006 10:16 PM


Thread Tools
Search this Thread
Quick Reply: car runs bad after 20 minutes


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.