Sound system fuse blows - Corvette Forums - Corvette Enthusiast Site


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-15-2017, 12:44 PM
Junior Member
Thread Starter
 
Join Date: Aug 2017
Posts: 1
Default Sound system fuse blows

Just bought a 1995 convertible and radio keeps blowing fuse sometimes right away and others 10 minutes later. Radio clock and CD ejection etc works after fuse blown but sound and antenna shuts off. When I purchased car antenna didn't work and previous owner gave me a new aftermarket antenna that came with car but had no instructions. Installed it everything worked until car is started then it blew a 20amp fuse in main fuse block under hood that didn't blow until new antenna installed.. I did notice a wire that was grounded with 3 others at the original antenna that was cut off. The wire is the 1 that goes up around and at top of rear drivers side fender well that is cut and there is no sign of other end of wire. May be the problem anyone know what that ground is to be connected to. Any help would be greatly appreciated.
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 04:11 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.