Notices
Corvette C1 & Corvette C2 1953 through 1967

1967 alternator issuue

  #1  
Old 08-06-2011, 07:28 PM
Junior Member
Thread Starter
Join Date: Aug 2011
Posts: 1
Question 1967 alternator issuue

I am having problems with my 1967 435 alternator. I had it rebuilt and I was told that the core was burnt up. I installed the rebuilt, but is is running extremely hot. I changed the voltage regulator and it is still running too hot to to touch. The battery checks good and the output on the alternator is putting out approx. 14.5 volts and when I measure the current draw at idle it ranges from 9 to 11 amps. Is this too much? If so what should it be? The car has a ammeter gauge and is registering just pass center and increases when revving engine. Douse anyone have any ideas as to what the problem could be? Thanks

Can a battery with higher cranking power cause this problem?
 

Last edited by Bsuky; 08-06-2011 at 07:33 PM. Reason: Addition
  #2  
Old 08-07-2011, 05:00 PM
Junior Member
Join Date: Aug 2011
Location: Independence MO
Posts: 2
Default

Check your ground on the voltage regulator as well as the ground wire that bolts to the back of the alternator. Bob
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
*026041*
Corvette C6 Forum
4
12-03-2006 04:36 AM
TealC4
Corvette C4 Forum
3
09-26-2006 12:59 AM
Fuzzy74
Corvette C3 Forum
1
06-26-2006 09:24 AM
Lee Willis
General Tech
2
03-22-2006 03:22 PM
itzfrank
Corvette C3 Forum
3
01-10-2006 09:15 PM


Thread Tools
Search this Thread
Quick Reply: 1967 alternator issuue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.