Notices
Corvette C4 Forum 1984 through 1996

94 C4 A/C clutch will not engage!

  #1  
Old 06-25-2016, 01:39 PM
Junior Member
Thread Starter
Join Date: Oct 2005
Location:
Posts: 7
Default 94 C4 A/C clutch will not engage!

I changed the compressor,Orfice tube and accumulator plus every O ring I
could get at.
I have a A/C gauge manifold set.
I'm showing 115 psi on low side and 130 psi on the high side with the engine off.

System was vacuumed down.

When I first entered the freon (134A) it started taking it. The clutch engaged for about 2 seconds, went off, engaged again,went off and stayed
off!
I tried jumping the low side pressure switch and that didn't do anything.

The codes just show 09 low freon,duh!

When I disconnect the negative side of the battery it just does the same quick on off then off again (clutch)

I did it one more time and the engine actually quit after it started because I guess the clutch engaged. When I cranked it again by the time I got out of the car the clutch was not engaged.

So far I have put 2 12oz cans of 134A into the system.
I can see freon in the clear round glass between the gauges.

It's suppose to get in the triple digits this weekend!
Multi-Quote This Message

Reply
Reply1/1
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lunati383
General Tech
5
03-27-2007 03:43 PM
ernie22golf
Corvette C4 Forum
1
12-27-2006 06:47 PM
jafone
Corvette C3 Forum
1
06-12-2005 11:43 AM
crausch
Corvette C5 Forum
0
05-25-2005 03:31 PM


Thread Tools
Search this Thread
Quick Reply: 94 C4 A/C clutch will not engage!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.