Notices
Corvette C4 Forum 1984 through 1996

Static in radio

  #1  
Old 10-14-2018, 10:39 AM
Junior Member
Thread Starter
Join Date: Apr 2008
Location:
Posts: 22
Default Static in radio

Okay, here goes. I have a C4 85 vette. There is static in the radio. When the engine is idling the static is super loud very low bass sound. When I accelerate the frequency increases to a very high pitch and get quieter. It has the Bose system in it. So what could be the problem and how can it be fixed. Any help is greatly appreciated.
 
  #2  
Old 10-15-2018, 02:33 PM
Ladybug's Avatar
Member
Join Date: May 2018
Location: Pensacola, FL
Posts: 68
Default

I gave up and bought a new radio.
 
  #3  
Old 10-16-2018, 12:15 PM
73shark's Avatar
Super Moderator
Join Date: Apr 2006
Location: KC, MO area
Posts: 2,744
Default

Did that fix the problem?
 
  #4  
Old 10-17-2018, 09:13 AM
Ladybug's Avatar
Member
Join Date: May 2018
Location: Pensacola, FL
Posts: 68
Default

I don't know if the new radio fixed the problem or that everything was handled, moved around, etc., when putting in the new radio. I needed an updated one anyway so took a shot. Something worked.
 
  #5  
Old 10-17-2018, 10:24 AM
73shark's Avatar
Super Moderator
Join Date: Apr 2006
Location: KC, MO area
Posts: 2,744
Default

I suspect a capacitor failed on the old radio which was allowing the alternator induced noise to come through.
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.