Notices
Corvette C4 Forum 1984 through 1996

Suspension Question

  #1  
Old 12-15-2014, 09:12 PM
Junior Member
Thread Starter
Join Date: Dec 2014
Posts: 1
Default Suspension Question

96 corvette lt4, front suspension question:

I'm about 2 days into installation of the midamericamotorworks wedge lowering kit and getting a little frustrated. I have removed the original rubber located on the top side of the spring and installed the wedges.

When I reinstalled the leaf spring, even after cutting/modifying the aluminum retainer, the wedges do not sit flush with the frame (top of wedge on the top of the spring to the surface above the leaf spring), and the bolt does not have enough threaded surface to press the wedges flush to the frame. Is this normal?

On the stock suspension, is the leaf spring engaged with the surface above it at all times, or does it have some travel before the original rubber would contact the surface above it.

Any help would be greatly appreciated, as the car is just sitting on jack stands at the moment.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
docmbnbkos
Professional Racing
9
07-28-2016 07:08 PM
94 Black on Black
Corvette C4 Forum
5
09-02-2007 01:37 AM
bobbyj
Corvette C4 Forum
3
09-25-2006 11:07 PM
stram8777
Corvette C3 Forum
1
03-07-2006 09:54 AM
korvette4u
Parts/Other Sales
1
08-06-2005 01:18 PM


Thread Tools
Search this Thread
Quick Reply: Suspension Question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.