Notices
General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Idle problem after warm up

  #1  
Old 07-08-2009, 09:57 AM
Member
Thread Starter
Join Date: Oct 2006
Posts: 59
Default Idle problem after warm up

90-L98-60K mi.- 1 owner-Starts great, warm up smooth, 5 miles out I get the rough idle and surging throttle as I drive. New dist. cap and rotor, new plugs with 300 mi. on them, Ohm test on the plug wires shows good wires. New battery and alternator in last year. Have not tested fuel pressure due to no guage. Am thinking it may be fuel or vacuum related. Fuel filter and fuel pump are original. One note: I show the car at indoor shows a couple times a year and I do not drive it very often. Last winter it set for 5 months in the garage. Would appreciate some sound advice or even experienced speculations. I think I might be getting to old for this hobby but love my Vetts. Thank you.
 
  #2  
Old 07-09-2009, 06:22 PM
Banned
Join Date: Oct 2007
Location: South Jersey
Posts: 594
Default

First off - do you use fuel stabilizer? Your car sits a lot. It sounds like you may have sour gas in the tank, that will make anything run poorly - or not at all. Secondly - try using some Techron (Chevron) Fuel system cleaner with some fresh high octane gas and getting it out on the highway to clean it out (translation = FLOOR IT ! !). Third - is your oil level where it should be? Not enough oil can cause hydraulic lifters to not have enough pressure and contribute to rough idle. Fourth (am I counting right?) - maybe there is a sensor going bad like a map or maf sensor..... damn computer controlled cars need all of their input data to be "happy" otherwise they act stupid. And lastly - how's the air filter? Engines like a rich mixture when cold but not when hot - a clogged air filter can cause a rich condition - something else to **** off your computer.
I hope that helps, at least it is the stuff you can check or try yourself. If these don't work then it's time to take it to the shop and let them figure it out.
 
  #3  
Old 07-14-2009, 08:46 AM
Senior Member
Join Date: Sep 2006
Posts: 103
Default

I would check your EGR. This will cause surging if it is not operating correctly.

CG
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
deansmachine
General Tech
0
09-11-2008 07:08 AM
Vetteatlast
Corvette C4 Forum
8
04-06-2008 06:41 PM
Callipjm
General Tech
3
03-06-2007 09:42 AM
06 Vette
New Member Area
4
01-23-2006 10:24 PM
Richvette
Corvette C4 Forum
4
10-05-2005 12:39 AM


Thread Tools
Search this Thread
Quick Reply: Idle problem after warm up


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.