Notices
Corvette C1 & Corvette C2 1953 through 1967

1965 heater blower motor

  #1  
Old 11-01-2007, 12:02 PM
Thread Starter
Join Date: Nov 2007
Posts: 2
Default 1965 heater blower motor

I am having a problem with the heater blower. Replaced blower motor.(old one did not run) Now after checking circuits, switch, grounds, etc. it will run then shut off. If I replace the fuse, it will run and shut off ( fuse tests ok). I have replaced the rheostat in the heater box to no avail. Any suggestions? THANKS EVERETT
 
  #2  
Old 04-12-2008, 07:25 AM
Thread Starter
Join Date: Nov 2007
Posts: 2
Default RE: 1965 heater blower motor

Found the problem with the blower motor. It eventually lead to other electrical "glitches." The whole problem stemmed from a corroded fuse block, connections, fuse terminals,etc. Replaced fuse block. Everything seems normal now. Just thought I would pass this on FYI.
 
  #3  
Old 04-12-2008, 08:16 AM
Join Date: Jan 2007
Location:
Posts: 236
Default RE: 1965 heater blower motor

glad ya found it. many thanks for getting back and letting us know
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MarksGoldie1986
Corvette C3 Forum
1
10-30-2013 09:31 AM
srgord
Corvette C5 Forum
1
10-04-2008 05:42 PM
ShadowF1
Corvette C4 Forum
5
01-27-2007 04:00 PM
crankyyank
Corvette C3 Forum
4
10-02-2006 08:55 PM
dilling
Corvette C3 Forum
0
11-29-2005 12:49 AM


Thread Tools
Search this Thread
Quick Reply: 1965 heater blower motor


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.