Notices
Corvette C4 Forum 1984 through 1996

1992 LT-1 Security Problem?

  #1  
Old 07-01-2014, 04:25 PM
Junior Member
Thread Starter
Join Date: Jul 2014
Posts: 2
Default 1992 LT-1 Security Problem?

Corvette neophyte here in need of some help! I just bought a used 1992 Corvette with the LT-1 engine, 6 speed manual, 81k miles. It runs good with no hesitation, misses, etc, but has been showing an occasional problem.
When I am driving down the road, occasionally, the dash will show "sys" and the Security light will flash on and off. The car does not always do this, but it does happen with some regularity. The manual says this is a problem with the security system and it should be taken to the dealer

Also, sometimes, when I have been driving it, and I park it for 10 or 20 minutes, when I try to restart it, the engine will turn over but will not start. It will usually turn over once and then stall - it does not continuously crank, as though it were not getting gas. Usually, within 5 minutes or so, the engine will finally start and everything will be fine. The engine will then run perfectly. Is this possibly related to the security error light?

Anyone able to suggest what might be wrong? Is it the computer, Opti-Spark distributor, or what? How can I go about figuring out what is going on? Can I figure this out myself or do I need to go to a dealer? I'm not much of a mechanic, but I'm a fast learner! Thanks!
 
  #2  
Old 07-07-2014, 09:37 AM
Member
Join Date: Aug 2013
Posts: 63
Default Sys Light

Being noone has responded I'll throw a little out there. First off my 86 does not have the OptiSpark on it so I can't speak to that. I've had an occassional SES and ABS light come on and off without a reason. First suggestion if to see if you can get an scan on the computer and see if it's throwing a code or not. Another thing is if you have not picked up a factory service manual, do so as soon as you can. Both a scanner and fsm will be invaluable over time.
Getting back to mine, I've found reference if either the battery is low or the alternator isn't putting out enough juice it can cause random lights to come on and go off. In your case the first things I'd do is check the battery and alternator plus check all your grounds to insure they're making good contact.
It may or may not solve your problems but electrical issues can cause other indicators (lights) that may not be related to the true problem and these are easy to check and potentially fix first.

Good luck
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Spoke
General Tech
0
05-11-2009 06:39 AM
kbuck
General Tech
1
12-16-2008 05:25 PM
miguel391980
Corvette C4 Forum
12
01-14-2008 09:05 AM
RobertAz2005
Corvette C4 Forum
2
05-25-2006 04:08 PM
bullet2five
Corvette C4 Forum
1
03-31-2006 09:29 AM


Thread Tools
Search this Thread
Quick Reply: 1992 LT-1 Security Problem?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.