Notices
Corvette C4 Forum 1984 through 1996

84 bogging on accelleration, not drivable

  #1  
Old 08-28-2013, 06:12 PM
Junior Member
Thread Starter
Join Date: Aug 2008
Posts: 1
Question 84 bogging on accelleration, not drivable

hi, my 84 has been sitting for a few months & im trying to get it going again. it will start and idle fine, and you can rev it up and it revs fine in neutral but, when you get out on the street it falls flat on its face. it runs kind of like the choke is still on. so far i have checked the wires (about 3 years old), plugs only have about 1000 miles on them. i put a new tps & map sensor on it, pulled the ecm out and checked for cracked solder joint & it looked fine. vaccum is about 19-20lbs, i pulled the fuel pump (about 5 yrs old & an 85'), cleaned the pickup strainer & put in fresh gas. changed the fuel filter, and rebuilt the injectors they look like they have a nice steady flow on both tb's. i have oxygen sensors & a new egr on its way. is there something else i should be checking out? i was thinking of ordering a new spark module & ignition module. im thinking its not a fuel issue because you can rev it up when its parked and it is getting plenty of fuel.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
95C4yourself
Corvette C3 Forum
3
11-18-2008 12:40 PM
scuba steve
Corvette C3 Forum
4
06-03-2007 10:41 PM
Zanador
Corvette C4 Forum
1
05-28-2007 09:10 PM


Thread Tools
Search this Thread
Quick Reply: 84 bogging on accelleration, not drivable


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.